Supercycle - Service Disruption – Infrastructure Provider Outage – Incident details

All systems operational

Service Disruption – Infrastructure Provider Outage

Resolved
Partial outage
Started 12 days agoLasted about 7 hours

Affected

Supercycle App

Partial outage from 9:12 AM to 11:52 AM, Operational from 11:52 AM to 4:24 PM

Supercycle API

Partial outage from 9:12 AM to 11:52 AM, Operational from 11:52 AM to 4:24 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Update
    UTC
    Update

    Full connectivity has been restored across US regions with our provider.

    We are monitoring closely to confirm everything remains stable before marking this incident resolved.

  • Monitoring
    UTC
    Monitoring

    We experienced a service disruption due to an outage affecting one of our infrastructure providers. During this time, some customers were unable to access Supercycle or experienced intermittent errors.  

    To restore service as quickly as possible, we migrated our application to our European infrastructure, and the platform is now operational.

    While the service is available, you may notice slightly increased response times as traffic settles on the new infrastructure. We are continuing to monitor performance closely and will provide further updates if necessary.

    We apologise for the disruption and appreciate your patience.